Wednesday, May 26, 2010

Chromium on Ubuntu 10.04 Slower than Firefox?

Maybe I'm being unfair. After all, I have been having networking problems with my Ubuntu 10.04 (Lucid Lynx) virtual machine running in VMware Workstation 7. Seems to be tied to a DNS problem. The VM doesn't pick up the DNS server addresses from the DHCP server on my network (though it gets an IP just fine). I thought the solution was to point to Google's free DNS servers. Worked for awhile, but then stopped. I tried using the DNS servers on my wee home server and DSL modem device and that worked for awhile too, and then stopped.

I finally tried my ISP's DNS servers and that seemed to take hold, though I don't know why. It shouldn't make a difference but I've been surfing from my Lucid Lynx VM for two days now without a hitch. That leads me to my second problem.

I'm a big fan of Firefox so naturally, use it on all my Linux and Windows machines. I've tried Google's Chrome web browser on a Windows VM and like it, so I decided to install Chromium on the Lucid VM. Seemed to go great guns at first but then hit major snags.

Actually, I was having problems in both Firefox and Chromium which all seemed to be tied to my general networking problems for the VM. For the past two days, I've been surfing the web just fine with Firefox, though. Time to try Chromium.

For a minute or two, it seemed great. I thought I could give Chromium a real workout and see if it really was faster than Firefox, just as the speed tests between Firefox and Chrome suggest when run on Windows. I've got some bad news.

Firefox continued to let me surf the web at lightning speed, but after a few minutes, Chromium slowed down to a wounded crawl. I tried Googling the problem but only came up with a slow video playback problem in Chromium on Ubuntu reported at

Admittedly, before I had the chance to investigate further, I had to leave for work, so I won't be able to make more tests until I get home tonight. I suspect the issue may still be tied to Ubuntu Lynx running as a VM and the associated networking problems, but I can't be sure. Until I get home and have a chance to look at this more completely, has anyone else had an experience with poor Chromium web browser performance in Ubuntu 10.04?


Saturday, May 22, 2010

Happy 30th Anniversary "The Empire Strikes Back"

In honor of the 30th anniversary of the release of the Star Wars film The Empire Strikes Back, I'm posting a photo of a star destroyer. You are probably saying "So what?" but this photo is special to me. I bought it at a Science Fiction convention in Los Angeles a full month or more before Star Wars (1977) was released. It was my first real look at the world George Lucas created. Enjoy.

Tuesday, May 11, 2010

Copiers have hard drives?

I don't think much about copying machines. I just make my copies, print what I need to print, fax what I need to fax, and scan what I need to scan. What I didn't realize is that since about 2002, commercial copying machines have been built with hard drives that store as images everything you have ever copied on your machine.

Now imagine you manage the copying machines for a medical center, insurance company, police department, or other organization that routinely prints and copies secure and confidential information. Imagine if some of the machines you manage are getting older and you replace them, surplusing the old machines for resale. Anyone who buys your old machines could potentially remove the hard drive and pull the data off of it; data that consists of all the documents ever processed through the machines. Am I being paranoid? Watch this:

Am I still being paranoid? Maybe your company should update its security plan to include how to dispose of copying machines. Just a thought.


Sunday, May 9, 2010

Ubuntu 10.04 Update: Networking

Not sure if this is an issue with the Lynx or with the fact that it's a VM (VMware Workstation 7). I've noticed over the past few days that networking's been spotty at best. Web pages take forever to load or the pages don't load and the connection times out. Same for twitter in twittergadget and Gwibber. Tried both the Firefox and Chromium browsers thinking it would make a difference but nada, tostada.

I'm aware that there's a wireless networking problem associated with the Lynx, but I'm using a strictly wired LAN with a DSL connection to hit the Internet. I can "refresh" the connection by rebooting the Ubuntu VM, but as of today, the connection only lasts a few minutes before it starts acting dodgy again.

Ubuntu itself is set to acquire a dynamic IP address and as a VM, it's network adapter uses NAT. The other VMs (Windows machines) aren't experiencing any similar problems. Also, my host PC and other computers on the LAN aren't having a problem. If it was just a Firefox issue, I'd suspect the problem listed at might be it, but not with Chromium showing the same behavior.

Any ideas?


Friday, May 7, 2010

Do Chimpanzees write The Great Gatsby?

I named my blog "A MillionChimpanzees" to illustrate the vast multitude of people on the web, all blogging about all things, great, small, and silly. It's as much a way to make fun of my own efforts as it is anyone else's. With that in mind, I read this comic this morning and absolutely had to share it as well as the link to the original source. Enjoy.


Monday, May 3, 2010

Ubuntu 10.04 LTS Lucid Lynx First Impressions

Yeah, I know. There are about a million blog articles of this nature floating around on the web, but what the heck. Blogging is all about freedom of speech and expression of opinions and ideas. Here's what I've got so far on the Lucid Lynx.

First off, I was amazed by the fact that I could quickly and easily download the ISO for the 32-bit desktop. It was only about 24 hours after the initial release when I gave it a shot, and there were no delays at all. I find torrents obnoxious, so I did the straight download directly from No muss, no fuss.

I joke that I don't try a new Windows desktop OS until the first service pack is released. That's usually pretty good advice, but even with Linux, I don't download and install a brand new release of a distro on my production machine. In this case, I ran the ISO directly in VMware Workstation 7 to give it a shot. I used the easy install option just for giggles. This bypasses the manual configuration for the OS which isn't always a good idea, but I figured the worst that could happen is that I'd experience a major fubar and have to blow away the VM.

Everything worked well. Installation was quick and the current version of VMware Workstation automatically installs VMware Tools for Linux, so it's an almost totally hands off experience. Then, when the GUI came up, I hit a snag. The mouse worked fine, but the keyboard was totally non-responsive. This could have been an Ubuntu issue, a VMware issue, or maybe wireless Dell keyboards just don't work and play well with Ubuntu. I fired up Google and started my search.

I found just about a ton of posts in different threads at the Ubuntu forums including this one and this one. They all give more or less the same advice about solutions, but I specifically referenced a thread dealing with Ubuntu 10.04 and VMware Player, which worked out for me just fine. After using the virtual keyboard option to enter my password, I was able to login and thereafter, my wireless keyboard behaved as expected.

I haven't had a lot of time to play with the Lucid Lynx VM as yet, but there were a few things I took care of right away. First, I installed Ubuntu Tweak, if for no other reason, than to be able to put a folder for my home directory on the desktop. It offers a lot of other great features as well, but it disappoints me that so many simple configuration options don't come with Ubuntu "off-the-rack".

There are a large number of "what to do after you install Ubuntu 10.04" blogs and tutorials around, and I chose the one featured at because it seemed to be reasonably comprehensive and wasn't afraid to use the apt-get system to tweak Ubuntu.

I didn't follow most of the steps in the tutorial, at least so far, but I did run sudo apt-get install ubuntu-restricted-extras to enable Adobe Flash Player, JRE with Firefox plug-ins, and a few other things. I might even get around to installing the Google Chrome browser just to try it out on Linux, but Firefox serves me for now.

Oh, and I installed GIMP, which was a breeze using the Ubuntu Software Centre. I'll post more details as I get the chance to do something more substantial with the Lynx.